home *** CD-ROM | disk | FTP | other *** search
/ PC World Komputer 2010 April / PCWorld0410.iso / hity wydania / Ubuntu 9.10 PL / karmelkowy-koliberek-desktop-9.10-i386-PL.iso / casper / filesystem.squashfs / etc / dkms / template-dkms-mkdeb / debian / rules < prev   
Text File  |  2009-04-24  |  881b  |  55 lines

  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3.  
  4. # Uncomment this to turn on verbose mode.
  5. #export DH_VERBOSE=1
  6.  
  7. DEB_NAME=DEBIAN_PACKAGE
  8. NAME=MODULE_NAME
  9. VERSION=MODULE_VERSION
  10.  
  11. configure: configure-stamp
  12. configure-stamp:
  13.     dh_testdir
  14.     touch configure-stamp
  15.  
  16.  
  17. build: build-stamp
  18.  
  19. build-stamp: configure-stamp 
  20.     dh_testdir
  21.     $(MAKE)
  22.     touch $@
  23.  
  24. clean:
  25.     dh_testdir
  26.     dh_testroot
  27.     rm -f build-stamp configure-stamp
  28.     -$(MAKE) clean
  29.     dh_clean
  30.  
  31. install: build
  32.     dh_testdir
  33.     dh_testroot
  34.     dh_prep
  35.     dh_installdirs
  36.     $(MAKE) DESTDIR=$(CURDIR)/debian/$(DEB_NAME)-dkms NAME=$(NAME) VERSION=$(VERSION) install
  37.  
  38. binary-arch: build install
  39.  
  40. binary-indep: build install
  41.     dh_testdir
  42.     dh_testroot
  43.     dh_link
  44.     dh_strip
  45.     dh_compress
  46.     dh_fixperms
  47.     dh_installdeb
  48.     dh_shlibdeps
  49.     dh_gencontrol
  50.     dh_md5sums
  51.     dh_builddeb
  52.  
  53. binary: binary-indep binary-arch
  54. .PHONY: build clean binary-indep binary-arch binary install configure
  55.